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Getting Started

Assemble your data

We assume that you have already created a dataset, using GIS software such as MapInfo or ArcView or – for point data only – a database or spreadsheet such as Access, Dbase or Paradox. The dataset will probably consist of one table which contains:

either longitude (X) and latitude (Y) values for point objects (such as site locations);

or points, lines or polygons stored as GIS objects in MapInfo or ArcView format.

You should also have (although this is optional):

· A thumbnail and a detailed view (GIF or JPG images) of your data which you can prepare by saving an image of the map from your GIS or desktop mapping program;

· An HTML file describing the dataset (including copyright information etc.) which you can prepare using a web page editor or wordprocessor.

Note: You will save a lot of problems if you choose a name for the metadata table which is compatible with table names on your database server (allowing for the addition of four extra characters). Avoid very long names and names with spaces or punctuation characters. Stick to A through Z, 0 through 9, and underscore(_). Do not use + ; : , - % $ @ * ^ etc.

To avoid confusion, it is generally best to use the same name for the metadata table (with a TMD extension) as for the main dataset table (eg with .SHP, .SHX, and .DBF extensions for shapefiles, .MIF and .MID extensions for MapInfo; .JPG or .TIF extensions for registered image files).

Making the dataset TimeMap compatible

In order to make a dataset compatible with TimeMap, you need to:

1. create a suitable metadata table – in the first instance a disk file (table) containing the necessary metadata. This file can be created using the TimeMap Metadata Wizard, which is part of the TMT toolkit program.

Making the dataset ECAI compatible

To make the TimeMap dataset an ECAI dataset you need to 

2. Register the dataset with the ECAI metadata clearinghouse;

3. Upload the data to a suitable server accessible across the Internet.

The registration and upload functions are also part of the TMT toolkit program.

The TimeMap Toolkit

The TimeMap Toolkit program, TMT.EXE, provides all the tools you need to create metadata, register datasets with the ECAI metadata clearinghouse and upload the data to a remote data server.
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The toolkit program has a simple pulldown menu structure: 
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Some elements of the structure will be greyed out until a connection has been established to the ECAI metadata clearinghouse or until a suitable file has been selected:

File menu:
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Using The TimeMap Wizard    

[image: image4.bmp]
The easiest way of creating the required metadata table is through the TimeMap metadata wizard (File > TimeMap Wizard). 

The TimeMap metadata wizard reads the data file you select and automatically creates the required metadata so that the dataset can be accessed by the TimeMap TMView software. 

The wizard opens a tabbed dialogue which will initially show only the pulldown list of connections and Browse File button: 
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Click the Browse File button to browse for the datasets you want to process. You can browse for MapInfo MIF files (.MIF), ESRI Shapefiles (.SHP), Access databases (.MDB), Dbase tables (.DBF) or Paradox tables (.DB). Delimited ASCII files will be supported soon. 

After you select a file, TMT will show all the files of that type in the chosen directory. You can choose any of the files shown by selecting them from the list:

[image: image6.png]TimeMap metadata wizard
Source

Type in, select or biowse path/connecion to souce fs/database

[Fina_outine_m.she
[china_provinces_dmshp
lehina_tivers.sha.
IUSA_Counties.shp
Jusa_outine_lowres.shy
Jusa_sates Tm.shp
[work_sites shp.

Problem Report G

Newt &





The wizard can be navigated with the Previous and Next buttons, or by clicking on the tabs at the top of the dialogue (when they are displayed).

Setting general parameters

When a dataset is chosen, the wizard displays the General panel:
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You must set the following information on this panel, using the pulldown lists for map object type, time variation type etc., and browsing for the thumbnail, sample and documentation files:

· the type of map objects (point, line, polygon or bitmap). The wizard will choose an appropriate type where possible (e.g. Shapefiles define the type of map objects they contain). You can set this to None if you only want to serve textual (attribute) data;

· the type of time variation (no date fields, unique data, unique range, instance date, instance range – see detailed TimeMap data preparation manual for an explanation);

· thumbnail and sample files (bitmaps representing the entire dataset – thumbnail – and a detail of the dataset – sample). These must be prepared in advance by capturing screen images or saving the map window to a bitmap file (GIF or JPG – use the former for most maps, the latter for air and satellite photos); 

· documentation file (an HTML file, with or without images, providing information on the dataset including details such as source, copyright, fair usage or publicity for the data provider). This must be prepared in advance using a web page editor;

· link mask provides a means of linking to web pages generated for individual records in a database. An example might be:


http://www.acasian.gu.edu.au/county.cgi?GBCode= [ID]


[ID] will be replaced with the value of the ID field in the dataset

· The default set pulldown allows selection of sets of appropriate default metadata for different projects. The TimeMap project team can add default sets for large projects on request, thus minimising repeated entry of data such as project team, addresses and copyright information.

For more information on these data fields and the thumbnail, sample and documentation files, please consult the detailed TimeMap data preparation manual.

After filling in the fields, the General panel will look something like this: 
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Selecting data fields

Click on the Field Definition tab to select fields which will be identified for special roles in the metadata such as identifying the record uniquely (ID) or specifying the date range for the item. This panel also determines which fields would be the default fields for upload to a data server:
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Note that the first two fields have been identified in the Role column as the Instance ID and Instance Description fields; that these two fields have been checked for upload; and that these two choices have been greyed out in the list on the right. You may not agree with the wizard’s choice of ID and Description fields (if any), in which case you should double-click the fields (or uncheck and recheck the Upload box) to remove the setting in the Role column, select a different field and double-click the Role on the right to set the Role column for the selected field.

Since, in this example, we have selected Instance Range for the type of time variation, the dataset must contain data columns specifying a feature reference, a start date and an end date. These roles have been marked with bold in the right-hand part of the panel. The list will vary according to the choices made on the General panel. For each of these roles, select a field on the left and then double-click the Role in the list on the right. The Role column will be filled in with the selected role.
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Any fields for  which there is a value in the Role column will automatically be checked for upload. You should check any other fields which you feel the users of your data should download when accessing the dataset remotely (over the internet). Important fields are key data describing each record or those fields which the user is likely to search by. Do not check long textual fields, comments, notes etc. as these will substantially slow down the user’s access to the data owing to the extra time taken to download long textual fields.

When you have selected all the fields and set all the special roles in the Role column, click the OK button. If you have not selected a field for each required special role, the wizard will warn you as, for example:
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The wizard will now create a TimeMap metadata file containing appropriate TimeMap and default ECAI/Dublin Core metadata, as defined in the ECAI metadata clearinghouse.

Editing The Metadata

After you create a metadata file using the TimeMap wizard, it is displayed in a file editing window. Several files can be open in different editing windows:
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This example shows a fairly complete set of both descriptive (Dublin Core) and TimeMap connection metadata. 

The darker shaded fields are those which have multiple values selectable from a pulldown list. Branches in the tree-structured list of available metadata elements on the right can be expanded or collapsed by clicking on the + and – symbols. Elements can be inserted into the data by double clickiong on the element name.
ECAI Descriptive Metadata

The ECAI/Dublin Core metadata, shown here, is largely blank, since the wizard does not know details such as creator’s name, copyright or subject keywords. In future versions the wizard will pick up more of this information where it is available, but for the moment it knows nothing of this sort of descriptive metadata. You should fill in these metadata following the guidelines in the ECAI Metadata Standard (available from http://www.ecai.org/ or http://www.timemap.net/ – also included as a help file on the TimeMap software distribution). 
TimeMap Connection Metadata

The wizard’s main function is to generate the appropriate TimeMap metadata required to make the dataset TimeMap compatible, as this metadata is less obvious -and more critical- than the descriptive metadata. The following screen shows a typical set of generated TimeMap metadata:

[image: image13.png]tates_Tm.tmd [Tl

Q:\imemap\software\di

ibution\Resources\S ampleDatatus:

Elment Soheme Vkic %[ inbocalimaceFieFien =
m TinelVaping Time Stamping (TM) NoDateFiekdd =T @ e
[ iminsence inkask FeeTen o ccon g o epibl v utoccbre T || (& decteslr
[B[imAccomparyingData Thumbnai Localimage Fie usa_sates_Im_hai et
[B[imAccomparyingDataangle. Localimage Fie usa_satos_Im_smi e
[E[imAccompanyingData Dockie | LocalDooument Fie | mapro_base. map him S ot
[B[im mopobi_pe Mep Obict Type (M) Pobgon @ dodte
[HimLoca.cisype 1S Type TM) ShapeFio = doype
minstance.TableName. FreeText usa_states_Tm & defomat
[B[imisance.dlaname FiesTen o doidenter
[B[im instance.descipion ioname. FreeTet name Sosouee
[Him instance.DefautDonnioadFieds FeeTert D AREANAME ABEREV L S
deoovenges
dcoovengey
il o= LH
Find @ Eloment " Vaiie 7 Tiettop ] Wethot for tine st - NoDateFelts,LriusDate, UiueRane, e

[ | Desoipivedosca) PtenceDee, stancefane Slct o pkdovn st Schem Type
ot fine stamina metha (Tinebian methodolocy L.
Bold-mandatory _Underscore=nonepealing Double-cic to expand node





You may also want to enter tm.links.fieldname which defines the data field containing URLs to which TMView will link when an object on the map is clicked with the URL-browse tool.

The tm.instance.LinkMask element contains a URL which includes a field name between [ ]. The field value will be inserted into the mask to create a complete URL to be used with the URL-browse tool in TMView.

For insertion and editing instructions, see next  section.

Metadata file list
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Metadata files stored on your local hard disk or network can be listed through File>List of metadata files. The list allows files to be opened by double clicking, and displays summary information about each file which is not available in a normal file directory listing.

The metadata file listing can either show files in the directory containing the last opened metadata file:
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or it can list all metadata files modified during the current session (note that this resets if you quit the program):
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[image: image17.bmp]  Click the open-folder icon to browse for files to edit and/or to change the working directory. 

[image: image18.bmp]  A folder icon left of a file in the list means that it is currently open in an edit window in the program (the edit window could be minimised). 

Status New indicates that a file has been created but not yet registered with the clearinghouse.

Status Registered means the dataset has been registered with the clearinghouse, but the metadata file has not been modified since registration. 

Status Modified means that the dataset has been registered with the clearinghouse and the metadata file has been modified since registration. 

Editing metadata files

Metadata files stored on your local hard disk or network can be edited either by browsing for them with File>Open or by double-clicking the file on the file listing window which can be opened with File>List of metadata files (see previous page).

Editing of metadata is carried out in the metadata editing window shown below:
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The darker shaded fields are those which have multiple values selectable from a pulldown list. 

Branches in the tree-structured list of available metadata elements on the right can be expanded or collapsed by clicking on the + and – symbols. Elements can be inserted into the data by double clicking On the element name. Underlined elements can only be inserted once into the metadata, whereas non-underlined elements can be repeated.

The two panels of this window can be rescaled relative to one-another by dragging the junction between them. Specific metadata elements can be located by typing their name into the Find field at bottom left.

The program will verify that you have entered all the metadata elements required, as well as internal consistency (e.g. if you have selected a range of dates, you must have specified two date fields for minimum and maximum). It will also verify existence of files and existence of fields in the datasets being described. Verification is requested with Edit > Verify.

Once the metadata has been completed, click the Save button, or close the edit window. 

The dataset is now ready for use as a local TimeMap dataset. To open it in TMView, simply click the Layers button and then Add Local dataset and browse to the TMD file created by the wizard.

Creating A Remote TimeMap Dataset

In order to create a remote TimeMap dataset, i.e. one which can be located through the ECAI metadata clearinghouse and downloaded over the Internet, you simply need to:

1. Register the dataset with the ECAI metadata clearinghouse 
 
(Internet>Metadata to Clearinghouse);

2. Upload the data to the SQL server which will serve it on the Internet 
 
(Internet>TimeMap data to SQL server).
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Registering a dataset

Choose Internet>Metadata to Clearinghouse from the menu. Depending on whether the dataset has been previously registered with the clearinghouse, you will get either a new registration window or an update window:
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Depending on whether the dataset has been previously registered, either the Register or the Update button will be greyed out. The registration details are shown at top right of the dialogue.

Previously registered dataset

If the dataset has already been registered, TMT will read the title of the dataset and its location from the clearinghouse, so all of these fields will be filled in. 

Warning: It is up to you to delete these datasets from your data server. If you change the server location or dataset name, any existing metadata table and/or data table will be ‘orphaned’ without an index entry in the clearinghouse. 

Unregistered dataset

If the dataset has not previously been registered, you will need to choose a location for it on a remote database server using the New Connection button. This opens the TimeMap Connection Manager dialogue shown below. The Connection Manager is a general-purpose tool for defining connections to SQL database servers. Currently (March 2000) it supports Interbase, Sybase, MySQL and any installed ODBC drivers on your computer. Support for Microsoft SQL server is under development.

You can choose an existing pre-defined database connection from the list, and click Connect or define a new set of connection parameters with New. 

The testbed connections shown on the example are general access databases which people are welcome to use for experiments. Data written to these databases may be deleted without notice.
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You will probably need to obtain database connection details from your System Administrator, and may need their help in getting the connection to the server to work.

The connection entries labeled testbed are open for anyone to write files to, but please do not plan to serve an ECAI dataset from these databases, as they will be cleaned out from time to time and may be deleted by anyone.

The TimeMap project can provide server space for serving ECAI datasets to ECAI members at no cost - contact the TimeMap project for creation of a personal database. 

Uploading data – the TimeMap DataPump

The TimeMap datapump uploads data from a local source to an SQL server database accessible over the Internet. In doing so it converts local GIS data in MapInfo MIF/MID or ESRI Shapefile format to a form which can be stored in a conventional textual SQL server database – special features for storing spatial or object data are not required.

You will of course require write access rights to a database on the target SQL server.

The data pump is launched with Internet > TimeMap data to SQL server, which displays the following tabbed dialogue:
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As with the TimeMap Wizard, initially no files will be shown. Select file(s) for upload from the pulldown list or by clicking the Browse Source data path/file button. The file list will show one type of file only – MapInfo MIF files, ESRI Shapefiles, Access MDB files, Paradox DB files, Dbase DBF files or text files.

Once the data source has been selected in the list of files on the left, the fields to be uploaded can be checked in the list on the right. Uncheck any data fields which are not required in the uploaded data.

It is critically important that any fields which have been specified in the metadata be checked for upload. Because the data pump can work independently of a metadata file, we are unable to verify that all relevant fields have been checked for upload.

Once the fields for upload have been checked, move to the Datasource Map View tab to set thinning parameters and inspect the data to be uploaded

Thinning map data

The Datasource map view tab in the data pump displays the map data to be uploaded (if applicable). The main choices to be made on this tab are whether or not the map data is to be uploaded - the data pump can also upload just the attribute (textual) data attached to the map objects – amd how much thinning of the data is required.

Thinning is the process of removing excess points from the data with the aim of reducing the amount of data to be downloaded over the Internet and increasing display speed. The reduction in space usage can be estimated from the box beneath the thinning pulldown – halving the number of nodes halves data volume. 
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TMT provides several levels of thinning which can be compared visually by zooming in the map (using the plus magnifying glass at bottom right). To recenter the map, right click on it. Thinning in the very low to low range is generally acceptable – average to high thinning may result in excessively jagged outlines. The two illustrations below show the effects of thinning on a zoomed-in map – the right-hand, thinned example reduces data volume by nearly two thirds:
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Choosing a destination

The final tab in the datapump allows choice of an SQL server database and table name to which the data will be uploaded. 
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The New Destination Connection button calls up the TimeMap Connection Manager dialogue, discussed earlier. If the dataset has already been registered with the clearinghouse, a destination server will have been defined and can simply be chosen from the pulldown. The dialogue will then show all the data tables which exist on that server (TimeMap metadata tables are not shown), allowing choice of an existing table to be overwritten, or specification of a new table.

It is important to ensure that the table name used is the same as the table name used locally (on your hard disk or network) for the dataset being uploaded.

Import/Export Of Metadata Definitions And Files

The Internet menu allows establishment of a connection to the ECAI metadata clearinghouse (Connect) and download of metadata definitions from the clearinghouse (Update local definitions). When you first attempt to access the clearinghouse, a user name and password are requested. This dialogue can also be used to add new users to the clearinghouse (Add New User button):

[image: image28.png]Clearinghouse login

[~ Select cleainghouss

ECal on Feis

=] e Cowea

[-Userinf

Username.

Passward

[JorNSON

AddNew User

Edillsz)

Frdlise;

X Cancel 2 Help





Updating of local metadata definitions makes a local copy of the current set of metadata definitions stored in the clearinghouse, ensuring that the program is using up-to-date element names, schemes, value lists and rules. The update may take some time on a modem and progress is shown by ticks on a progress dialogue.

Downloading metadata from the clearinghouse

It may be that a registered metadata file has been deleted or mislaid. The metadata can be retrieved from the clearinghouse using File > Download, which displays the following dialogue allowing selection of a dataset and download of the metadata:
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Only the metadata you have registered is shown in this dialogue - if you have registered no datasets it will be blank

Exporting metadata to HTML

The metadata export function is useful for two reasons:

1. Metadata entered can be cut and pasted into a web page editor to provide hidden metadata tags in a web page (improves visibility to search engines);

2. Metadata exported to an HTML file can be reimported to create a new TMD file. This is a useful way of copying repeated metadata from one dataset to another, similar, dataset without reentering all the metadata.

To export metadata to an HTML file, or to the clipboard, select File > Export HTML, which brings up a file browse dialogue for you to locate the TMD file to be exported. Once chosen the following dialogue is displayed:
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Use the Save to HTML button to create a file for import by Import HTML. Use Copy to Clipboard if you simply want to paste the HTML information into a web editor (be sure to paste in HTML mode).

Importing HTML format metadata

The File > Import HTML function will read any HTML file – including HTML files written with the File > Export HTML function, and identify any metadata elements in the file. 
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If the metadata elements found in the file correspond, as they do in this example, with those defined in the clearinghouse, they are listed in the upper panel. If they are not recognised they will be listed in the lower panel. The identifiable metadata may be saved to a new TMD file by clicking on Save to TMD file.

Having A Problem?

TMT and TMView have a special error reporting function, accessed through Help > Problem Report or the Problem Report button on the toolbar. This displays the following screen into which you can type details of your problem.

[image: image32.png]Error reporting

Please et as mich deail2 possibl descrbing the problem and then submi by emal f nlne) o pirt and s 0 61 2 3951 6352

1 was editing the file Provinces_4m.tmd, which | will email
you separately, but was unable to register it because
Verify says that the ID fieldname is missing. However, the
ID fieldname appears to be recorded. | think this is a bug
in the prograr.

Comel | sitratyenat | pin | watgoonn]

20-03-00 23:10 :1

System Info

Organization
Owner

CPU Intel Pertium

Windows Dir - C:AWINNT
System Dir - C:AWINNT\System
Application Dir - Q:\timemap\ s
Current DIr - Q:\TIMEMAP\SOF
Total Mermory :261492 KE
Available Virtual Memory 11991
Total Virtual Mermory :2097024
Drive Q: Tatal 25930752 K8, Fre

KT E— _l_I





When you click the Submit by email button, the program emails your message to the TimeMap project team,  plus a lot of background information on the initialisation and configuration files on your system, the version of the program you are running etc. (this information is shown in the righthand panel). This gives us extra information to help resolve the problem. 

In case you are not connected to the Internet, there is also a Print button to print out the report for faxing or mailing.

The first time you use this function you will need to set up your mail server to forward the email (Mail Account button).
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